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    Introduction


    So you are upgrading to Excel 2010.


    For those of you who are coming directly from Excel 2003 to Excel 2010, I want to congratulate you for skipping Excel 2007. You saved yourself the hassle of struggling with the only Excel version ever to not have a File menu. Many of the half-baked features added to Excel 2007 are now baked. The ribbon is confusing, but at least you can customize it in Excel 2010.


    Chapters 1 through 11 of this book introduce you to all the changes in the Excel interface. I give you strategies for finding things on the ribbon, but also the cool tips and tricks for dealing with the ribbon. You’ll see how to unlock the 1.1 million rows in the new Excel. You’ll learn about the vastly improved File menu (a.k.a. Backstage view) and all the other Excel interface goodies. You’ll also read about why Ctrl+C, Ctrl+V, Ctrl, V is going to become your new best friend.


    Chapter 12 introduces the new functions in Excel 2010.


    Chapters 13 through 20 deal with data wrangling and business intelligence. Pivot tables get a makeover and improvements (Chapter 19). And as you’ll learn, the new PowerPivot add-in is the best feature to happen to Excel in 20 years (Chapter 20).


    Chapters 21 through 34 will make your worksheets look great. You will learn about the new charting engine and data visualization tools. These chapters also cover SmartArt concepts, and they show you how to use document themes and cell styles to quickly format a worksheet. You’ll also learn how to remove the background from pictures.


    This book is the quick-hit summary of what’s been introduced in the past two versions of Excel. In my five others books about Excel 2010, I’ve already written 3,000 pages covering every feature of Excel. This book is designed for someone who uses Excel 2003 and knows it well. My goal is to get you up to speed with the new interface, show you how to leverage what’s new, and then get you back to work.

  


  
    


    1 Introducing the Ribbon


    By far, the biggest change when you upgrade from Excel 2003 to Excel 2010 is trying to find commands on the ribbon. Rather than the familiar File, Edit, View, Insert, Format, Tools, Data, Window, Help menu bar, you are now presented with large icons and words such as File, Home, Insert, Page Layout, Formulas, Data, Review, and View.


    Where to Find Commands in Excel 2010


    Here are some simple guidelines:


    
      	The Home tab contains the most frequently used commands. If you want to find something, start looking on the Home tab. Nearly everything from the Excel 2003 Edit and Format menus is located on the Home tab. Everything from the Excel 2003 Formatting toolbar is on the Home tab.


      	The most-used commands on the Excel 2003 Insert menu are not on the Insert tab in Excel 2010! Instead, commands to insert cells, rows, columns, and worksheets are on an Insert drop-down on the Home tab. Commands to insert a function or a name are on the Formulas tab. Insert Comment is on the Review tab.


      	The Pivot Tables command has been moved from the Data menu to the left side of the Insert tab.


      	Most Excel 2003 File menu commands are on the Excel 2010 File tab. This tab is called the Backstage view and is discussed in detail in Chapter 4. A few File commands are elsewhere. For example, Save Workspace is on the View tab. Page Setup and Print Area are on the Page Layout tab.


      	Everything on the old Window menu and most things from the old View menu are now on the View tab.


      	Help is now the blue question mark icon at the top right of the window. Everything else that used to be on the Help menu is now under File, Help.


      	Items from the Data menu are generally on the Data tab, with the exception of the Pivot Tables command.


      	The old Tools menu has been split among many tabs. You will find these commands spread among the Review, Formulas, Home, Data, View, and File tabs. Table 1.1 shows the break out of individual commands.

    


    Table 1.1 shows where you can find most Excel 2003 menu commands in Excel 2010.
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    Table 1.2 shows where you can find the commands formerly found on the Tools menu.
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    Table 1.3 shows commands formerly found on the Standard toolbar.
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    Ribbon Components


    The ribbon is the new interface at the top of Excel 2010. It consists of icons and words grouped into several tabs. Within each tab, icons are further classified into groups. In Figure 1.1, there are 4 icons in the Clipboard group of the Home tab and 10 icons in the Font group.
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    Figure 1.1


    Icons are classified in logical groups within each ribbon tab.


    Dialog Box Launchers


    In the lower-right corner of some groups, you will see a tiny icon showing a diagonal arrow. You can see this in the lower-right corner of Figure 1.1. This icon is a dialog box launcher. Click the icon to open a dialog box similar to the dialogs you are familiar with from Excel 2003.
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    Figure 1.2


    The mouse pointer is showing the dialog box launcher in the Font group of the Home tab. Dialog launchers are found in many groups.


    Icons That Really Contain a Drop-Down


    A lot of large icons look like a single icon until you hover over the icon. You will then see that the top half of the icon is a Paste icon, for example, and the bottom half of the icon is a drop-down with more choices related to the icon.
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    Figure 1.3


    The Paste icon is really an icon and a drop-down.


    Gallery Icons Fit Many Choices into a Tiny Space


    Some ribbon elements consist of a gallery of many different options. In Figure 1.4, the Chart Layouts gallery shows three thumbnails at a time.
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    Figure 1.4


    Three buttons on the right side of the gallery enable you to scroll up, down, or open the entire gallery.


    You can use the Up- and Down-Arrow button to scroll through three thumbnails. Or, click the third arrow to open the gallery and see all the options simultaneously (Figure 1.5)
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    Figure 1.5


    The third button next to the gallery is the More button. Click that button to see all the choices at one time.


    Making the Ribbon a Bit More Like a Menu


    Although there is nothing you can do to bring back the legacy Excel menu and toolbars, you can make the ribbon behave a bit more like a menu.


    Press Ctrl+F1 or right-click the ribbon and choose Minimize the Ribbon. When you do so, Excel hides the ribbon, as shown in Figure 1.6.
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    Figure 1.6


    Ctrl+F1 hides the ribbon, leaving only the tab names.


    After the ribbon is hidden, you have more room to work with your document. You can also later click any ribbon tab name to open the ribbon temporarily. After you choose a command, Excel returns the ribbon back to the view in Figure 1.6. At least this feels more like a typical menu system.


    Context-Sensitive Ribbons


    Occasionally, new tabs will appear on the right side of the ribbon. These tabs appear when the current selection includes SmartArt graphics, charts, drawings, pictures, pivot tables, pivot charts, worksheet headers, tables, ink, or when you are in the legacy Print Preview mode.


    These new tabs will stay visible as long as the object stays selected. If you click outside of your pivot table or chart, the tabs will disappear. If you are looking at an object and cannot find the tools necessary to edit the object, click the object to bring the tools back.


    Different Screen Sizes Show Different Icons


    If you frequently try to help coworkers over the phone, you want to be aware that the ribbon looks different at different sizes. If you have a massively wide monitor, you will see more icons than someone working on an older laptop.


    To demonstrate, Figure 1.7 shows the right side of the Home tab. You see 11 drop-down icons. If you were looking at this screen, you might tell a coworker to open the drop-down next to the word Fill.
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    Figure 1.7


    The Home tab at one screen resolution.


    In Figure 1.8, the Excel window is less wide. The Insert, Delete, and Format icons are now arranged vertically, and words are missing next to the words AutoSum, Fill, and Clear.
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    Figure 1.8


    Your coworker will insist that he doesn’t have an icon labeled Fill.


    At an even smaller screen width, the Insert, Delete, and Format icons are combined into a single drop-down called Cells. You have to open the Cells drop-down to see the Insert icon.
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    Figure 1.9


    As the Excel window shrinks, commands are consolidated into one drop-down per group.


    Eventually, if the Excel window gets small enough, Microsoft assumes that you cannot possibly be working in the worksheet and the ribbon disappears completely.
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    Figure 1.10


    Eventually, the ribbon disappears completely.


    Keeping Some Commands Always Visible on the QAT


    In Excel 97-2003, you always had quick access to icons for bold, italic, cut, paste, align right, decrease decimal, sort ascending, print preview, Chart Wizard, and more.


    With Excel 2007, these icons are spread across seven ribbon tabs, so the odds are that you will not always have access to the various icons that you might need. Microsoft addresses this problem with the Quick Access Toolbar (QAT).


    The QAT is a toolbar that is always visible near the ribbon. It appears on the left side of the screen, above the File tab. Although the QAT initially contains three icons (Save, Undo, and Redo), you can customize the QAT to hold all your favorite icons. One set of customizations can apply to all workbooks opened on the computer, and you can define a second set of icons to open for each specific workbook.


    [image: 01Fig11.jpg]


    Figure 1.11


    The QAT starts with three icons and a drop-down menu.


    When you open the drop-down menu at the right side of the QAT, Microsoft suggests some popular icons that you might want to have available all the time. In Figure 1.12, selecting Open Recent File adds that icon to the end of the toolbar.
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    Figure 1.12


    The drop-down includes a dozen commands you might want to add.


    In reality, you can add any of hundreds of commands to the QAT. Right-click any command and choose Add to Quick Access Toolbar, as shown in Figure 1.13.
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    Figure 1.13


    Right-click any command to add it to the QAT.


    If you find yourself using the QAT frequently, move it below the ribbon, as shown in Figure 1.13, by using the final menu item in Figure 1.12.


    You can customize the QAT in even more ways, too, as you’ll read about in Chapter 2.


    Finding the Elusive Mini Toolbar


    If you have used Outlook 2003, you might be familiar with toolbars that fade in. When you receive a new Outlook message, a notifier box starts to appear in the lower-right corner of the screen. This notifier shows the subject line, the first words in the message, and icons to immediately delete the mail or to open the e-mail. If you are busy working on a document and ignore the notifier, it slowly fades away. However, if you move the mouse toward the notifier, it solidifies so that you have time to click the Delete button to eliminate the mail if it is junk.


    The Mini Toolbar uses similar technology. I think it will appear much more frequently in Word and PowerPoint than it will appear in Excel. It is possible to use Excel 40 hours a week and never see the Mini Toolbar appear.


    Note: During the beta period, Microsoft has variously called this feature a Mini Bar, Mini Toolbar, and a Floaty. Although I prefer visiting the Mini Bar, it looks like Mini Toolbar will win out in the final version. When I write books for Que, the editorial guidelines there state that the T in toolbar is never capitalized. Although I generally agree with this, to me, Mini Toolbar is just a bad replacement for Mini Bar, and so I will capitalize the T. After all, you wouldn’t drive a Mini cooper automobile, would you?


    The Mini Toolbar is elusive in Excel for two reasons. First, it is relatively hard to select characters within a cell in Excel. It is easier in Excel charts or SmartArt graphics to select characters, but it is relatively rare to select just a few characters inside of a cell. Second, on many computers, the Mini Toolbar initially appears in a completely invisible state! If you don’t move the mouse pointer toward the completely invisible Mini Toolbar, it will never appear.


    In Figure 1.14, the Mini Toolbar is just starting to appear (as we select characters in a chart title and move up and to the right). The toolbar is so light, it is difficult to guess if it will even show up as this book goes through the printing press. The Mini Toolbar starts just above the e in the word Title.
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    Figure 1.14


    Select some text, move up and to the right, and a nearly invisible Mini Toolbar starts to appear.


    If you then hold the mouse still, the Mini Toolbar will remain in its nearly invisible state. If you move the mouse left or down, the Mini Toolbar will become completely invisible.


    However, if you move the mouse right or up by a few pixels, the Mini Toolbar sharpens completely into view.
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    Figure 1.15


    Move toward the invisible Mini Toolbar and it solidifies.


    The theory behind the Mini Toolbar is that a leading reason for selecting text is that you might be planning on formatting the text. The Mini Toolbar puts 17 popular formatting commands at your mousetip. You can do a fair amount of formatting without ever having to visit the ribbon or the QAT.


    Although the Mini Toolbar contains only 17 icons, a few of those icons lead to drop-down menus with significant variations. In Figure 1.16, the paint bucket icon opens to reveal flyout menus for patterns and gradients.
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    Figure 1.16


    Some icons on the Mini Toolbar lead to menus with hundreds of options.


    Mini Toolbar Versions


    The figures shown previously in this chapter represent the Mini Toolbar when you are formatting a chart title. If you cause the Mini Toolbar to appear when you are editing text within a cell, some buttons do not apply.


    Quadruple-click any nonblank cell and move the mouse pointer up and to the right. An abbreviated version of the Mini Toolbar with seven icons will appear. It doesn’t make sense to change the indentation of just a few characters in a cell, so Excel produces this version of the Mini Toolbar, shown in Figure 1.17.
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    Figure 1.17


    If you select characters within a cell, a miniature Mini Toolbar appears.


    If you right-click any cell, the full Mini Toolbar appears above the cell. This is by far an easier way to invoke the toolbar than by selecting characters within the cell. In this version of the Mini Toolbar, the Center Across Selection icon replaces the Send Forward icon.


    [image: 01Fig18.jpg]


    Figure 1.18


    Right-click a cell to access this Mini Toolbar.


    Customizing the Mini Toolbar


    Although you can customize the ribbon and QAT, you still cannot add icons to the Mini Toolbar in Excel 2010.


    When Does the Mini Toolbar Completely Disappear?


    As discussed previously, if you move toward the Mini Toolbar, it solidifies. If you move away from the Mini Toolbar, it disappears. You can move your mouse from 7 o’clock to 2 o’clock and cause the Mini Toolbar to fade in and out of view.


    However, once your mouse strays a certain distance from the selection, the Mini Toolbar disappears and will not reappear until you reselect the text.


    This distance is based on pixels. In general, though, if you move approximately 10 rows away from the selection in a spreadsheet with the default font and zoom, you will have hit the limit and the Mini Toolbar will permanently disappear.


    I can see many situations where you would move away from the selection (for example, to respond to an incoming e-mail notification). After you’ve moved too far away from the selection, you will either have to reselect the text or use the formatting icons in the Home ribbon.


    Permanently Disabling the Mini Toolbar


    The Mini Toolbar is fairly elusive in Excel and will rarely get in your way. However, if you want to permanently disable the feature, you can do so.


    From the File menu, choose Options. The first setting in the Popular category is Show Mini Toolbar on Selection. Uncheck the box shown in Figure 1.19 to disable the Mini Toolbar.
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    Figure 1.19


    Use this setting to permanently disable the Mini Toolbar.


    Surely There Is a Classic Mode


    I’ve been told that when Bill Gates saw the ribbon, he asked whether there would be a Classic mode. The Office user interface team convinced Bill that the ribbon would be too different and that there could not be a Classic mode. Bill Gates bought that argument.


    Okay, so the largest software company in the world cannot figure out how to do a Classic mode, but a lone programmer named Lin Jie is offering Classic mode for $15.95. Figure 1.20 shows the familiar File, Edit, View menus along with the Standard and Formatting toolbars. To buy the add-in, visit www.mrexcel.com/classicexcelmenu.html


    [image: 01Fig20.jpg]


    Figure 1.20


    Bring back the old Excel menus.


    Next Steps


    Chapter 2 shows you how to customize the ribbon and QAT.

  


  
    


    2 Customizing the Ribbon and Quick Access Toolbar


    Presumably, you are reading this book because you are upgrading from Excel 97-2003 to Excel 2010. You are going to be horribly disappointed with the limited customizations that you can do to the ribbon and Quick Access Toolbar (QAT). During the Excel 2007 era, it was impossible to customize the ribbon using the Excel interface, so the limited tools in Excel 2010 actually seem like a great improvement over Excel 2003.


    Adding a New Group to an Existing Tab


    You might feel like the Pivot Table command belongs on the Data tab rather than on the Insert tab. You can add a new group to the Data tab to hold the pivot table icons.


    First, look at the ribbon and decide where you want the new group to appear. Perhaps a good location would be between the Sort & Filter group and the Data Tools group.
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    Figure 2.1


    Decide where you want the new group to appear.


    Right-click anywhere on the ribbon and choose Customize the Ribbon.
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    Figure 2.2


    Right-click the ribbon to access this menu.


    The Customize dialog contains two large list boxes. You will first be working with the list box on the right side of the screen.


    Expand the plus sign next to the Data entry to see the groups on the Data tab. If you want a new group to appear after the Sort & Filter group, click Sort & Filter, and then click the New Group button below the list box.
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    Figure 2.3


    Choose where the new group should go.


    Excel adds a new group with the name of New Group (Custom). Click the Rename button below the list box.
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    Figure 2.4


    Choose to rename the group.


    Type a new name in the Rename dialog. Also, choose an icon. This icon will appear only when the Excel window gets small enough to force the group into a drop-down, as shown later in Figure 2.8.
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    Figure 2.5


    Type a new name and choose an icon to represent the group.


    Note: The 180 icons available in Excel 2010 are a far cry from the 4096 icons available in Excel 2003. As I pointed out at the beginning of this chapter, toolbar customization took a giant step backward after Excel 2003.


    After renaming the new group in the list box on the right side, it is time to turn your attention to the list box on the left side. It starts out showing Popular Commands. Use the drop-down above the left list box to change from Popular Commands to All Commands.


    Scroll down to the commands starting with Pivot. You will see a confusing array of commands. Click the first PivotTable icon, and click the Add button in the center of the screen. Click the second PivotChart icon, and then click the Add button. Click PivotTable and PivotChart Wizard, and then click the Add button.
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    Figure 2.6


    Choose icons to add to the new group on the ribbon.


    It is sometimes difficult to figure out which icons you want. There are two icons that say PivotTable. The first icon is simply an icon. The second icon is an icon with a rightward-facing triangle on the right side of the list box. That triangle indicates that the second icon is actually a drop-down that leads to more choices. That second PivotTable drop-down icon is the icon at the bottom half of the Insert tab’s Pivot Table group. It opens to enable you to choose between PivotTable and PivotChart. You might prefer to use that icon instead.


    Two PivotChart icons are available. Hover over each icon to see that the first one is the PivotChart icon available on the PivotTable Tools Options tab. You will also see that the second icon is the one on the Insert tab. The first PivotChart icon will be grayed out unless you are in a pivot table. The second PivotChart icon is the one that is used to create a new pivot chart from a dataset.


    Figure 2.7 shows the resulting group on the Data tab.
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    Figure 2.7


    The resulting custom group gets added to the ribbon.


    If you are wondering why you had to choose an icon back in Figure 2.5, it is for people who have the Excel window resized to a narrower width. If you make your Excel window narrower, the custom group will eventually get squished down to a single drop-down. Your icon will appear on that drop-down, as shown in Figure 2.8.
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    Figure 2.8


    The icon from Figure 2.4 shows up at a smaller window size.


    Small Icons vs. Large Icons


    Note back in Figure 2.1 that the Sort icon appears as a large icon with a caption and that the AZ and ZA icons appear as small icons without a caption. You are probably wondering how you can control your new group. How can you specify that the pivot table icon should be large and the pivot chart and wizard icons should be small? You can’t. At least not with the Excel interface.


    If you want to start writing some XML and VBA, you can gain control over the size and images used in the ribbon. For an excellent book on this daunting task, look for RibbonX: Customizing the Office 2007 Ribbon by Robert Martin, Ken Puls and Teresa Hennig.


    Adding a New Ribbon Tab


    I find that I spend most of my time on either the Home or the Data tab. If I could combine the left side of the Home tab with the right side of the Data tab, plus pivot tables, I would probably be able to spend all my time on one tab.


    Figure 2.9 shows a new MrExcel tab that reuses groups from other ribbon tabs to build a new tab.
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    Figure 2.9


    The MrExcel tab is a custom tab with my favorite groups.


    The general steps for creating a new ribbon tab are as follows:


    Right-click the Ribbon and choose Customize the Ribbon.


    Click New Tab at the bottom right of the dialog.


    Click Rename and give the tab a name.


    Use the Up and Down buttons at the right side of the dialog to move the new tab into the proper location.


    From the left drop-down, choose Main Tabs.


    In the left drop-down, expand an existing tab and find an existing group that you want to add to your new tab. Click that group and click Add.


    Repeat step 6 to add additional groups.


    You can reuse a custom group that you created previously. In the left drop-down, choose Custom Tabs and Groups. You can move the Pivot Table (Custom) tab created earlier in this chapter onto your new ribbon tab.


    Click OK to finish customizing the ribbon tab.


    To sum up the customization for the ribbon, you can add new custom groups or a new ribbon tab. You cannot add or remove icons from an existing group. If you have an existing group with six icons and you want to remove two, you will have to build a new custom group with the four icons that you want to keep. You cannot force certain icons to be large and others to be small.


    Customizing the QAT


    Initially, the QAT is a tiny toolbar with three icons. It appears on the left side of the screen, above the File tab.


    There are five ways to customize the QAT:


    
      	Using the drop-down at the right side of the QAT to add any of 12 popular icons


      	Right-clicking any icon on any ribbon tab and choosing to add to the QAT


      	Right-clicking any icon in the QAT and choosing Remove from the QAT


      	Right-clicking the QAT and choosing Customize Quick Access Toolbar to access the Quick Access Toolbar pane of the Excel Options dialog


      	Selecting File, Options, Quick Access Toolbar to customize the QAT

    


    Using Excel Options to Customize the QAT


    Chapter 1 discussed quick ways to make small customizations to the QAT. If you need to make many customizations to the QAT, you will want to use the full-featured customization tool available in the Excel Options dialog.


    The Excel Options dialog box pane to customize the QAT is similar to the pane for customizing the ribbon, with a few changes.


    The top-left drop-down still offers choices such as Popular Commands, All Commands, Commands Not in the Ribbon, and Macros. You can find an icon in the left list box and use the Add button to add it to the QAT.
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    Figure 2.10


    Select icons to add to the QAT.


    A drop-down above the right list box will allow you to add icons to All Workbooks or to only a specific open workbook. Icons added to a specific workbook appear after the icons added for all workbooks.


    The Modify button works only for icons from the Macros category. You can choose a new icon and words to appear in the tooltip.
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    Figure 2.11


    You can only modify icons for macros.


    The left list box always starts with a <Separator> entry. This is not an actual command, but will draw a vertical bar in the QAT to break your commands into groups.


    To restore the QAT to its original set of three icons, click the Reset button.


    Any custom groups that you added in the Customize Ribbon tool will appear in the list of All Commands. These will appear as a drop-down on the QAT.


    Adding Too Many Icons to the QAT


    If you add too many icons to the QAT, only the first row of icons is shown on the QAT. A More Controls icon appears at the right end of the QAT. Click the More Controls icon to see a second row of QAT icons. If you have even more icons than will fit on the second row, a scrollbar at the right edge of the second row of the QAT will enable you to scroll through the additional icons.


    Caution: Chapter 8 talks about using keyboard shortcuts. Although it might be possible to memorize some keyboard shortcuts, it will be hard to memorize the keyboard shortcuts associated with the QAT. The QAT icons are assigned shortcut keys on-the-fly every time that you press the Alt key. If certain icons are grayed out in the current context, their shortcut keys are shifted right and applied to other icons. If you want to reliably memorize certain QAT icons, be sure to add them to the leftmost section of the QAT, before any icons that may occasionally be grayed out.


    Sharing Customizations


    Let’s say that a coworker has developed a new ribbon tab that has a great set of customizations. You can ask the coworker to export the customizations, and then you can import those to your computer.


    Note that exporting customizations is an all-or-nothing proposition. You cannot export only a portion of the customizations. When you export customizations, you will get the new ribbon tabs, the new groups, and any QAT changes.


    To export the customizations, use the Import/Export button at the bottom of either the Customize Ribbon or Quick Access Toolbar pane of the Excel Options dialog. The file created will be a UI file. Move this file to another computer, and then use the same button to import on the new computer.


    Next Steps


    Chapter 3 discusses a new security method called Protected mode.

  


  
    


    3 Protected Mode


    I like Protected mode.


    I am sure that you regularly get files from other people in your company. They arrive via Outlook or you download them from an Internet site. I always worry that those people aren’t smart enough to avoid getting viruses or that they actually hate me and would maliciously slip something bad into the workbook_open macro to cause problems with my computer.


    In Excel 2003, if you opened a file with a macro, it stopped right away and made you choose whether to enable or disable macros. Have you ever thought about this question? How the heck should I know whether I should enable the macros when I haven’t even had a chance to look around the worksheet (or examine the macro code, if you are comfortable with that)?


    When you answered Enable Macros in Excel 2003, you were really taking a risk.


    Now, any file that comes from a potentially dangerous location is open in the new Protected mode in Excel 2010. Here is the cool thing about Protected mode: You can look at the workbook. You can scroll through it or go to other worksheets. You can look at the macros. When you are convinced that the file is safe, you click a button and the workbook is available in regular mode.


    This is brilliant. I get to actually look at the workbook, and while doing so it cannot harm my computer. I get to make an educated decision as to whether the workbook may prove harmful.


    And, you know what? A lot of the time, you won’t even have to leave Protected mode. You can look at the worksheet, see what you need to see, and close the workbook.


    If you need to edit the workbook, use the button shown in Figure 3.1.


    [image: 03Fig01.jpg]


    Figure 3.1


    When you are convinced that the workbook is safe, enable editing.


    Which Workbooks Open in Protected Mode?


    Basically, any file that did not originate on your computer can open in protected mode. Specifically, these workbooks open in Protected mode:


    
      	Files that you download from the Internet


      	Files in your temporary Internet folder


      	Files that you open from Outlook


      	Files that fail validation

    


    If you want to adjust those settings, click the words in the information bar in Figure 3.1, and then choose Protected View Settings. You can turn off Protected mode for one or more of the situations shown in Figure 3.2.


    [image: 03Fig02.jpg]


    Figure 3.2


    When you are convinced that the workbook is safe, enable editing.


    New Rules for Workbooks with Macros and Links


    If you frequently use workbooks that have macros or external links, you will like the following improvements.


    Normally, if you open a workbook that has macros, you must click the Enable button to use the macros (see Figure 3.3).


    [image: 03Fig03.jpg]


    Figure 3.3


    You have to explicitly enable macros.


    In Excel 2010, when you decide to enable macros for a workbook stored on a local drive, that workbook becomes a trusted document. When you open that same file again, you will not be asked to enable the macros.


    This should allow you to keep the setting for Disable All Macros with Notification as shown in Figure 3.4. In Excel 2003, this setting was known as Medium Macros Security.


    [image: 03Fig04.jpg]


    Figure 3.4


    This setting now forces you to choose to enable macros once for each file stored on a local hard drive.


    In a similar fashion, files with links to external workbooks have a new behavior starting with Excel 2007. Instead of being forced to answer the question of whether you want to update external links, the external links are automatically disabled until someone clicks Enable Content (see Figure 3.5).
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    Figure 3.5


    External links are initially disabled for each file until you click this button.


    In Excel 2010, when you choose to Enable Content the first time for a file stored on a local hard drive, you will no longer be asked to enable content. You will instead be taken directly to a dialog like the Excel 2003 dialog where you get to choose to enable links or not (see Figure 3.6).
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    Figure 3.6


    After the file is trusted, you are forced to choose if you should update links or not.


    You can control the startup prompt for one specific workbook by choosing Data, Edit Links to display the Edit Links dialog. In the lower-left corner, choose Startup Prompt. In the Startup Prompt dialog, you have the choices shown in Figure 3.7.
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    Figure 3.7


    You can override the behavior for the trusted document.


    Untrusting a Document


    If you decide to enable content on one workbook, and then discover that the workbook is doing something detrimental, you don’t want those macros or links to automatically work the next time you open the workbook.


    You cannot change the trusted status for one workbook. You can reset the trusted status for all workbooks. Choose File, Options, Trust Center, Trust Center Settings, Trusted Documents, Clear (see Figure 3.8)
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    Figure 3.8


    To untrust one document, you have to untrust them all.


    Using Trusted Locations


    If you want to trust your own workbooks but not trust the workbooks created by others, you can start saving safe workbooks in one specific folder and set up that folder as a trusted location.


    In the Trust Center, use the Trusted Locations item in the left navigation to set up trusted locations.


    Beware of Group Policy Settings Set by Your IT Department


    If your employer licenses Office 2010, the people in IT are allowed to set up certain defaults in Group Policy. These defaults can be a bit dangerous in the hands of someone who doesn’t know Excel.


    Overzealous IT people might choose to never show you the message that external links have been blocked. This allows the completely insane situation where you think that you have correct calculations in the workbook but you are not getting the correct numbers from external links. If your IT people want the company to restate numbers to the Securities and Exchange Commission, this is a fine choice. Otherwise, they should not force this setting through Group Policy.
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    Figure 3.9


    The IT department can force this insane option on everyone in the company.


    Another setting that you can control through Group Policy is to force certain file extensions to always open in Protected mode. To check this setting, use the File Block Settings tab in the Trust Center.
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    Figure 3.10


    You or the IT person setting up Group Policy can control which file types open in Protected mode.


    Next Steps


    In Chapter 4, you will learn the theory behind the new Backstage view.
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* Base SmartArt on a formula

547.001.3

ISBN 075161 .
ol 7516151470013

About the author:
Bill Jelen is a Microsoft MVP and the host of MrExcel.com. Like you, he

doesn't have time to read a 1,000 page book about Excel.
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